Build crashing after settings


#1

Hello I was trying to build the MR Scene for iPhone XR but I received an error exception saying that the device’s resolution isn’t compatible.

Whenever I ran the application, I would get prompted to set the settings. After I click done, it will crash the application immediately. Is there a reason that this is happening?

I have not change any scripts and am utilizing scenes from the provided sdk.


#2

Could you let me know the sample application you are trying to run? Are you using Unity? Could you also let me know the iOS version on your phone and the Xcode version you are using?


#3

We are using Unity. The iOS version we are using is 12.3.1. The device we are using is iPhone XR. The Xcode version we are using is 10.2 (10E125).

I will also forward this email message that I sent here:

We were trying to build the MR Scene using Bridge Engine for iPhone XR but instead received and error exception stating the following:

“Terminating app due to uncaught exception ‘Color camera resolution’, reason: ‘The current device does not support this resolution mode.’
Whenever we ran the application, we would get prompted to set the settings. After clicking done, it will crash the application immediately.

Another problem that we are having using your Structure SDK is that upon building the sample projects ( Fetch, Simple, Ball Physics )

We received the following error in XCode:

“const STRStreamConfig structureStreamConfig = STStreamConfigRegisteredDepth320x240; - Use of an undeclared identifier.”

We replaced the following line with:

“STStreamConfigDepth320x240” and it fixed the error however…

upon building the sample scenes and launching it on the phone, it would always crash whenever we attempted to scan by pressing on the scan button.

Is there a reason that this is happening? We would like to know asap if there’s a fix or if we’re doing something wrong. We did not modify any of the content that was provided within the package.


#4

Thanks for the quick response.

Could you let me know which version of Unity you are working with?


#5

We are using 2018.3.11f1 for Structure SDK
2018.3.14f for Bridge SDK


#6

With the Bridge Engine, it appears that this is an issue with the display resolution on your iPhone XR. We don’t directly support that iPhone and it’s resolution of 1792 x 828 pixels.

You might be able to finagle the sample applications to work by manually setting the DPI in player Settings within Unity.

This could also be why you are seeing a crash with the Structure SDK (iOS) Unity AR samples.

Do you have another iOS device you can test with?


#7

Thank you for your repy.

Does iPhone XS work with Structure / Bridge SDK?


#8

I attempted to change the resolution in the Player Settings but it didn’t give me any option to change it to a specific DPI – Only to change from Disabled Resolution Scaling Mode or Fixed.

Do you have any idea on how to achieve this? Thank you.


#9

We do support the iPhone XS.

As for DPI setting change, you can do so through the Build Settings > Player Settings > Resolution and Presentation.


#10

Hello, I went there but it doesn’t give me any option to change it.

Here’s what I see in the Resolution and Presentations tab:


#11

Change Resolution Scaling Mode from Disabled to Fixed DPI.


#12

Hello,

I have tried that prior but the problem still persist. Is there another way?


#13

Unfortunately, since we do not “actively” support the iPhone XR, there might not be a way to get the Bridge Engine to work with your phone. This is because we do not sell a headset that fits that iPhone.

I will notify our developers of this crash to see if there is an easy fix for you.


#15

Hello,

I have built the project onto a iPhone XS. I also calibrated the lens.

Inside the bridge Demo, when I built it on the phone.
I was prompted to scan the room which I did. The quality of the visuals are clear at this step.

After I pull the trigger, the next step, the scene becomes very blurry and unbearable as to what I can see in the headset. Is there anything I can do about this to get better quality visuals?


#16

Could you show me a screenshot of the visuals you are seeing?


#17

This is a screenshot of the visual

This is how it looks with just the phone. Similar case for when using VR mode.


#18

Do you happen to have the Scaling Resolution mode set to a fixed DPI still?


#19

Yeah that solved the problem.

Thank you. Will forward more questions I have any.