building for ios 10.3.2


#1

Hello all!
Very exited to join this forum and start developing with structure sdk!
I have to make an architectural render with an AR background as a start. I did that with a project tango before and it was pretty straight forward.
I have previously worked with PCs only and am completely overwhelmed with apple operating system.
I am trying to load Fetch onto our iPad and I am failing miserably for a few days now.

my Mac has an OS X 10.11.6 and cannot be updated/downgraded
the iPad has ios 10.3.2 and cannot be updated/downgraded as well
I tried downloading different versions of Xcode (7.3,8.3) and I am getting a: “could not find developer disk image” error on Xcode.
Plus, does it make sense that every time I open Xcode it takes like 10 minutes to “verify”?
I am using unity 2017.3.0f3.

Any solutions will be much appreciated!

Thanks,
Adi


#2

Solution Below:

The difficulty you are having with Xcode and it “verifying” could be related to the age of the device you are using and the age of the version of Xcode you have installed on your machine.

Also, Unity 2017.3.0f3 hasn’t been tested with the current downloadable version of the SDK. You may run into difficulties trying to use that version of Unity with the Structure SDK Unity Packages. Please check the “getting Started” PDFs for more information on which versions have been confirmed to work.


#3

Thank you!
so if I install an older version of unity it will work with OS 10.11.16, Xcode 7.3 to ios 10.3.2?
or do I have to downgrade my iPad’s ios system to a version that has been tested like 9.3?


#4

Thank you!
so if I install an older version of unity it will work with OS 10.11.16, Xcode 7.3 to ios 10.3.2?
or do I have to downgrade my iPad’s ios system to a version that has been tested like 9.3?


#5

You will need an older version of Unity to run our unity packages. Please make sure you download the latest version of the SDK first, however, and read through the “Getting Started” pdfs.

I have not personally dealt with the Xcode issue you are seeing, so you will need to do your own research on how to fix that, if the above stackoverflow article doesn’t help.


#6

I downloaded a previous, compatible version of Unity,
I downloaded the latest version of SDK,
read the PDFs thoroughly,

Now when I try to build the project I am getting this error:


#7

Managed to resolve it, there is just a new syntax I hope.
but when I try to deploy the project to my iPad- still “could not find developer disk image”

If I cannot build from unity, the sensor is useless to me.
Please help!

thanks


#8

I will be investigating this issue today. I do appreciate your patience.

Could you tell me which version of iOS you have running on your iPad? 10.3.2 right?

Could you also tell me which version of Xcode you have? 7.3 right? and which version of Unity you are using?

I’ve been able to successfully test the Fetch Example in the StructureUnityAR.unitypackage with the following setup:

Xcode 9
iOS 11.2.2 on an iPad Air 2
Unity 2017.1.1f1

Could you please try to update your version of Xcode to something a bit newer as the newest version is Xcode 9?

My theory is that you will need to update your version of Xcode, as noted by the following articles:


I believe that you will need Xcode 8, at least, to be able to work with iOS 10.


Announcing Structure SDK 0.7.1: Enhanced Calibration and Improved Memory Usage
#9

I am using OSX 10.11.6
This is my firm’s computer and cannot be updated.
Therefore apple does not allow me to download the latest version of Xcode. My mac does not support it.
Building for iPad ios 10.3.2
tried both with unity 2017.3.0f3
and with several releases of unity 5
Tried with Xcode 7.3,7.2 and 8

Thank you for your help


#10


#11

any reply? anyone??
still not working…
I updated my xcode


#12

The warning message “You Can’t use this version of the application XCode with this version of OS X” is a Apple issue.

It is because you are using a newer version of Xcode on an older version of the MacOS.

Please reach out to them directly to see what you can do to solve this issue: https://support.apple.com/