can not get the head

Using the new SDK, MarkII hardware, cannot scan the head.
Before, we used MARKI, which was always good, but after update to MARKII, no more scanning heads. Is it the reason for setting parameters?

As above, I cannot get a scan of the head。

Which box placement strategy are you using? In the image, is the box floating in the air, or flat on the ground? Also, which preset are you using for scanning?

@sbin @ecajuste has a good question. Without a ground plane, it’s important to make sure you use the Body preset, which will optimize for this sort of thing.

Other things to consider–what does your scene look like? If you are next to a window with lots of extra IR, you may end up having more trouble. In that case, switching to the Outdoor preset might be more helpful. Also, consider switching IR Autoexposure on. Let us know if anything improves!

thanks for your reply.
I used the default Settings and didn’t do anything different.
It’s just a little bit of integration.
the same code,it’s ok for MarkI, but not ok for MarkII.

I used the default parameters and didn’t change them.
The box is floating in the air, in fact, it has a tripod that holds the model up. As you say, it’s like a model floating in the air.

If the box is floating in mid-air, do you have it set to be a fixed distance to the camera?

@sbin Mark II has a lot more freedom and features than the original Structure Sensor, so you will need to adjust some of the settings. The Default Preset is intended for objects with a ground plane, and your head does not have one.

Switch to the Body Preset and let us know if you can capture the scan.

Yes, it can be scanned when it has a ground plane. But now I can’t scan it with a tripod.
Do you have any Suggestions to modify this?

You are not giving enough information to help solve the problem but I’m assuming your bounding box is placed too close to the model for scanning. The different presents have different optimal ranges. The closest scans should be done with the STCaptureSessionPresetBodyScanning preset, but if your fixed bounding box is closer than the minimum distance of 36cm, there’s no way that the scanner will pick up anything within that distance that may fall inside your bounding box. If you’re using the STCaptureSessionPresetDefault preset, the minimum distance required becomes 57cm.

You can check out this link for more info about which present may be best for you, but I’m pretty sure you mean to use the body preset.

Please confirm whether or not you are using a bounding box that’s fixed to the camera or whether this helps at all.


I used the lowlevel version for development and did not find this function.Do you have this setting at lowlevel? STCaptureSessionPresetBodyScanning

I think you said about the function “startStructureSensorStreaming” in low level project.
but I can’t get the type of scann.
could you give more advise about this question.
if I can support more information about the scenario pls tell me . I will supply more information .thanks.

now I can got the body scanner.
the lowlevel demo can not setit.

but new issue occur, I can get the body only parallel the body.
did you konw how to set the parameter to adjust it?