Can you run Structure sensor on raspberry pi 2?


#21

I’m puzzled because I haven’t been able to repro the raspivid behavior.

Couple of questions:

  • Assuming you have an iPad etc., have you upgraded the Sensor firmware?

  • Have you tried a different pi power supply? What’s the output current of the one you’re using?

  • Have you tried running with the sensor plugged in to its power supply?

  • Do you happen to have a second rpi 2 board to test on?

By the way, I ordered a pi 3 today and will test when it arrives.

-jim


#22

I have 4 raspberry and 4 SS.
I have tried all the combinations.
Firmware 2.0 (up to date)
While I use the SS connected to the Raspberry, It is always under charge with its power supply.
I have only one test to try: reinstall Raspbian on a new SD and try again.


#23

Following the installation instructions on github.com/occipital/openni2, is required to install JDK 6.0, but no available candidate for Raspberry… I have found JDK 7: sudo apt-get install openjdk-7-jdk. Please update GitHub.


#24

ok Jim,
I have found something to work on.
I have reinstalled everything on a new SD with a new SS and a new Raspberry Pi 2.
Just after the installation everything worked without problems.
As you have observed, installing OpenNi2, there where no conflict between OpenNI demo programs ad camera demo programs.
Then I have dowloaded and recompiled the userland-master from github/raspberrypi/userland, to be able to integrate the camera API in my cpp program.
After this installation I have found the conflict again.
So the problem is around userland-master and camera API…


#25

That’s really good to hear, thanks for letting us know! Will be very interested in hearing how the remaining details are resolved.

-jim


#26

Hi Jim,
after a night I have found the key to the problem…
To install and use the API of the raspberry camera I have followed the instructions in this link:


It works and its easy enough, but generate the conflict that I have described.
The problem is the way to build the userland-master it suggest.
The solution is to build the userland-master with ./buildme
After that everything works without problems.
As simple as that !


#27

Sorry for the late bump. Do I need to build OpenNI2 from source / gitHub, or can I use the (in my case ARM) binaries hosted here? https://structure.io/openni


#28

Maybe this will help:


#29

Indeed it will! Thanks a bunch!