Can't install SDK for Mac under MacOS Catalina 10.15

Hello good people,

I’m try to install the SDK under MacOS 10.15, I have Cmake 1.15, Xcode11.3.1 fully installed. However when running: Scripts/build.sh I got Cmake error message:


CMake Error at /Applications/CMake.app/Contents/share/cmake-3.16/Modules/FindPackageHandleStandardArgs.cmake:146 (message):
Could NOT find OpenGL (missing: OPENGL_INCLUDE_DIR)
Call Stack (most recent call first):
/Applications/CMake.app/Contents/share/cmake-3.16/Modules/FindPackageHandleStandardArgs.cmake:393 (_FPHSA_FAILURE_MESSAGE)
/Applications/CMake.app/Contents/share/cmake-3.16/Modules/FindOpenGL.cmake:397 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
External/GLEW/build/cmake/CMakeLists.txt:40 (find_package)

– Configuring incomplete, errors occurred!
See also “/Users/Fei/matlab code/currentWork/StructureSDK-CrossPlatform-0.7.3-ROS/Builds/macos-release-x86_64/CMakeFiles/CMakeOutput.log”.
See also “/Users/Fei/matlab code/currentWork/StructureSDK-CrossPlatform-0.7.3-ROS/Builds/macos-release-x86_64/CMakeFiles/CMakeError.log”.


Anyone in the same situation? It is said after MacOS 10.14, the default installation does not work anymore. After trying some “solutions” on google, which do not work, I turn to you.
All the best, John

After having all files in build folder deleted and run again, it worked.

Glad you get through it. I haven’t upgraded my environment to Catalina but I will add this into my test case when we release next version.