Do I have a Sensor malfunction?


#1

Hi forum,

I am a new user of Structure Sensor and didn’t have any problems setting up the hardware nor calibrating the lens using Occipital’s app (I run a 10.5 inch ipad pro with 256GB).

Problems starts when using the sensor with these 3 apps: Room capture, Scanner, Canvas.

  • Room capture: The scan seems to work fine for a few seconds, then the 3D data starts to drag towards the left in jaggy steps. This is also a behavior observed in Canvas and Scanner.

See video: https://youtu.be/h5uSOHcbU28

  • Scanner: The object being scanned - and the highlighted scanning area are dragging towards the left in incremental steps until we lose the scan area and scanned model altogether.

See video: https://youtu.be/Y8Fv9ehsoXM

  • Canvas: Even though I don’t move the ipad at all, I get error messages asking me to move slower and the scan fails.

Did I miss something in the setup of the sensor? Or could this be a hardware malfunction?

Thanks in advance for your help.

/Nicolas


#2

It doesn’t seem like there is an issue with your scanner, but there might be an issue with the IMU on your iPad evident from the jumpy tracking capabilities shown in both videos. Please restart your iPad to see if this helps. If not, please reach out again!


Ipad camera no longer working
#3

Hi Anthony,

I tried restarting the ipad (and tried to turn the compass on/off under location services) but it didn’t help at all with using the sensor. Is there any way to find out if the problem really is with the ipad’s IMU?

Update: I’ve taken a look at the sensor data using the “Sensor Kinetics” app. And it does show unusual behavior especially under orientation - see video below. We’ve also tested the Sensor Kinetics app on another ipad where this problem didn’t show up.

https://youtu.be/I2cnYLZ4VbI


#4

Great! I am glad that you have, at least, discovered the root of your tracking issue. I would suggest that you either take the iPad to an Apple store to have them check it out, or just contract Apple’s customer support: https://support.apple.com/contact