Interchanging sensor between iPhone and iPad


#1

I received my bridge yesterday and have gotten fantastic results with the iPhone inside the bridge.

I also bought a bracket for my 9.7 inch iPad Pro. However, when I take the sensor off of the iPhone and put onto the iPad, I get very bad results. Here’s a screenshot of the Fetch app for comparison:

I’ve run the calibration on the iPad several times. I’ve ensured that the calibration has the correct settings (the non-adhesive bracket and wide angle lens).

Is there a difference between sensors for iPads and iPhones? Is there a way to check my gyroscope etc. settings on the iPad?

EDIT: The iPad does perform fine without the wide angle lens. But does not work with the lens.


#2

I am having issues with the lens on iPhone as well, not tried it on the iPad yet. I think the wide angle lens is playing up when used with the current SDK. I assume the new SDK thats going to come with Bridge will fix these issues as its built for use with the headset etc (at least thats what im hoping :slight_smile:)


#3

Interesting. I am getting great results with wide angle lens on the iPhone.


#4

Jumping in here – The Bridge Engine (for Bridge customers for now, just sent to them today) does indeed support the lens, as does the new Canvas app for iPad. Structure SDK itself doesn’t yet support the lens, but we plan to add support in a coming release. By the way, the lens is great for tracking-centric or large-scale apps, but won’t really make an improvement in object scanning use cases.


#5

Interesting! We are particularly interested in room-scanning, so the lens does indeed help.

But, I don’t see how that explains the lens working for iPhone but not for iPad? The iPad bracket came with a lens of its own so that seems odd to not support it.


#6

Which app did the lens work with on iPhone? The latest version of Calibrator should support the lens on both iPhone and iPad, and it can show you a “preview” screen to indicate whether things are well-calibrated.


#7

Then lens with iPhone worked with all the structure apps I tried (this was before the Bridge Engine was released to Bridge owners).

In the calibrator, the color match seemed to work fine. Also in other apps like the Viewer everything seemed ok. It was only other apps like Fetch, Structure, etc. that didn’t work on iPad with lens.

If it would help, I can take four comparison screenshots. iPhone w/ and wo/ lens. iPad w/ and wo/ lens.


#8

That’s interesting, unless you used a special version of Calibrator, I can’t imagine how the standard apps would have worked well.