Ipad camera no longer working


#1

Hi Forum,

I’m a new user of Structure Sensor. Yesterday I made my a post regarding problems with using the sensor when scanning a room and an object - see thread here.

As the problem may have been cause by the ipad IMU I have tried to first reboot - then reset all settings - and finally erase and reset the ipad.

After I have reset the ipad and try to use the sensor again my predicament got even worse as now the ipad camera is no longer working - and therefore all apps just show a black screen.

When I try to launch Cancas, Scanner or Room Capture it launches the app and closes it again right after the first screen.

I run iOS 11.1.2 and ipad pro 10.5.

/Nicolas


#2

We have seen this issue before with different versions of iOS 11:


Please try to hard restart your iPad again to see if it fixes the issue. If not, please use the following instructions:

To fix the issue you will need to do a factory reset to your iPad (You may need to do this multiple times). You can find instructions to do so here: https://support.apple.com/en-us/HT201252. Please ensure you backup all of your information prior to performing the factory restore.

We have not been able to reproduce this issue in house. Our suspicion is there is some part of the hardware enumeration process that sometimes gets skipped when installing the iOS 11. This is an issue with Apple’s installation process from what we can tell but we do not have the ability to modify the process.

Another way to double check the sensor is working is if you have another lightning connector iPhone/iPad you can test with. Simply download the Structure app to the other device and connect the sensor with the lightning connector cable and launch the app. From there you should be able to see a rainbow like depth stream. If you do use another iOS device, please make sure that the device is on a different version of iOS 11.