MKII Sensor Bounding Box Drift

An example of some of the difficulties we are having with the Structure Sensor II, both in our app and the Scanner sample app.

Bounding Box Drifting

Seeing this bounding box ‘drift’ on all three of the version 2 sensors we have here, even after using the ExpertCalibrator on two of them.

Have upgraded our app to SDK 0.10.1, but still seeing same issue.

Scanner app from App Store or version in SDK still have the problem.

Upping IR Analog Gain seemed to help a little, but doesn’t stop the issue completly.

All apps are fine with version 1 hardware.

Have no idea what to try next, other than wait for another firmware or SDK release.


We’re seeing the same behavior. Are you also seeing the preview frame rate slow down after a few attempts to scan?


1 Like

Not even getting that far. :frowning:

On a whim I just now tried the 0.10.1 low level Scanner sample which seems to have more stable tracking!?

1 Like

Same here. Interesting. Suggests it’s an issue with the new SDK and/or STCaptureSession.

Having just converted to using STCaptureSession, to support new hardware, kinda reluctant to roll back just to fix the drift issue.


That, and also there’s no fine control over the Structure Core features in the low level API. (Probably what you were alluding to :slight_smile: )

Also, still seeing the “Please Charge…” message after only a few minutes of use.

Yep. And not triggering disconnect messages when you unplug the scanner, which v1 reliably does. They fixed my missing symbols though, so that meant I could pull the bridging code that was fixing that.

Hi Andy,

Are you still seeing the issue you reported above in 0.10.2?

Hi Jacob. Yes, still seeing the drift in 0.10.2. And MKII not showing a disconnect message, and MKII failure to report Sensor Name.

-Andy W

1 Like

Thanks Andy, I’ve logged these issues and we’ll be testing internally very shortly. I’ll update here after we’ve had a chance to review.


Looks like using the new 10.3 SDK, along with using STCameraPoseInitializerStrategyTableTopCube , helps a lot with the drift. I can get scans out of the new hardware now without in happening every time.

Unsure if that key alone fixed it, if it’s the new SDK, or it’s something else I have changed.

New SDK certainly seems to fix the other two issues: MKII disconnect and sensorName value. Thanks.

-Andy W