"Please put Model back in view" keep popping up with SDK 0.81


#1

with new SDK 0.81
modify scanner sample code with two lines:

  1. ViewController.h
    change
    const GLKVector3 initVolumeSizeInMeters = GLKVector3Make (0.5f, 0.5f, 0.5f);
    to
    const GLKVector3 initVolumeSizeInMeters = GLKVector3Make (1.0f, 1.0f, 1.0f);

  2. ViewController+SLAM.mm
    change
    options:@{kSTCameraPoseInitializerStrategyKey: @(STCameraPoseInitializerStrategyTableTopCube)}];
    to
    options:@{kSTCameraPoseInitializerStrategyKey: @(STCameraPoseInitializerStrategyGravityAlignedAtVolumeCenter)}];

try to capture the red spot (1cm in diameter) near the edge of object, “Please put model back in view” keeps popping up with the new Improved Tracker (0.8+)
when I switch it to “off”, but move the object near edge of desktop; the same message still pops up.

No problem found with old SDK 0.71


#2

Change your mapper kSTMapperVolumeHasSupportPlaneKey: @NO
and this article should help: SDK 0.6 Fix the Cube at a certain distance from the user


#3

I set it @NO, the message still popups.