Sample Apps working on latest Unity/Xcode?


#1

I’m new to Unity and Xcode but have myself a Bridge and Structure Sensor.
Running Unity 5.6 and Xcode 8.3.3 and Structure SDK 0.6.2

I have followed the PDF guide “StructureUnityAR Plugin” and installed the built app onto an iphone 6S iOS 10.3.3

When I try to run it it’s fine until you scan and then it crashes.
In Xcode, although it appeared to install to the phone ok, has come up with a couple of Deprecations and a whole bunch of Semantic Issues.

My question is, have others managed to get this going ok using this setup? It’s easier to learn when you know whether the tutorials work with the lastest versions or not.
Thanks in advance :slight_smile:


#2

Just to confirm - are you building for the structure AR samples or Bridge samples?
You mentioned the Bridge and the Structure AR samples are not compatible with it as far as I know (anyone?).

I didn’t have an issue building or running the sample apps for the bridge. They worked right out of the box first time. Not tried building the structureAR samples yet.


#3

The StructureUnityAR Plugin is known to be compatible with Unity versions 5.1.3f1, 5.3.2p4, 5.3.3f1 & 5.3.4f1. Can you download one of those versions of Unity and retry the examples to see if that helps?

Let us know if it does!


#4

Bridge samples? I’m using the Unity AR samples found in structure-sdk-0.6.2.zip
Are there special Bridge ones?
Which version of Unity were you using when you built it? (as per Anthonys comment below)


#5

Hey crewmark. Yeah, there are specific Bridge samples on Github:
Bridget, MixedReality, along with a Unity Package and a PDF with instructions to setup a VR scene.
The instructions specifies that the Bridge will only work with Unity 5.5.0 - Unity 5.6 will not build successfully.
Also Xcode 8.2 (Beta 9 is a no go :frowning: ), iOS 9.3 & 10.2