Scanning and scale


#1

Hi-
I’ve been using the scanning app and have found that all of my exported .obj meshes are very small when they’re opened up (I’m using Rhino). Does anyone know the reason for this of or if there’s a method of calibration.
Thanks-
BJ


#2

I noticed the same thing when I imported into Blender the outputted Obj file.

The mesh is not lacking detail so its just a case of scaling it up.

I think there is no way currently to scale up the captured mesh but maybe this would be a good feature to add?

Regards
Damien


Skanect vs. "Scanner" app
#3

The Scanner app exports obj files scaled such that 1 unit in the file = 1 meter in the real world. OBJ file coordinates are unit-less, so most CAD & modelling tools which import them will just assign the default system unit to the imported mesh, often scaling it like crazy.

In Rhino the default unit is millimeters, an imported scan of 1.85m-tall me would probably end up looking a bit like an ant =] Similarly, in Blender, I’d be a bit shorter than the 2-unit-tall default cube.

So what can you do about this right now?

  • Check the import dialog for a “units” or “scale” option - some tools have this for unit-less formats.
  • Try changing the system unit to meters before importing.
  • Most CAD & modeling tools will allow you to scale the model appropriately after importing as Damien suggests, or…
  • If all else fails, you can scale and re-export using another tool before using your primary tool. Meshlab and Blender are both free tools that can do this.

Scaling files acquired within "Scanner" App
Making scan actual size/measurements in Meshmixer
New to the forums? Introduce yourself here
#4

Thanks Evan- That’s great to know and makes total sense. I tried your suggestion (in Rhino) and created a workspace in meters than imported my .obj file, which now came in at what appears to be at full scale.
Thanks again for your help and fast reply!
Best,
BJ

evan structure@occipital.com 8/21/2014 2:26 PM >>>

The Scanner app exports obj files scaled such that 1 unit in the file = 1 meter in the real world. OBJ file coordinates are unit-less, so most CAD & modelling tools which import them will just assign the default system unit to the imported mesh, often scaling it like crazy.

In Rhino the default unit is millimeters, an imported scan of 1.85m-tall me would probably end up looking a bit like an ant =] Similarly, in Blender, I’d be a bit shorter than the 2-unit-tall default cube.

So what can you do about this right now?

  • Check the import dialog for a “units” or “scale” option - some tools have this for unit-less formats.
  • Try changing the system unit to meters before importing.
  • Most CAD & modeling tools will allow you to scale the model appropriately after importing as Damien suggests, or…
  • If all else fails, you can scale and re-export using another tool before using your primary tool. Meshlab and Blender are both free tools that can do this.

Posted by evan on 08/21/2014


#5

Hi Evan,

Thanks for the info. I think it would be great to have a way to pick the default unit in the outputted Obj or at some point in the SDK so you could say something like this:

_renderer->setDefaultMeshUnit(MESH_UNIT_METERS);

And has something in Structure.h like this

/// Mesh Unit Configuration
typedef NS_ENUM(NSInteger, MeshUnitConfig)
{
    MESH_UNIT_METERS         = 0, //Default operation
    MESH_UNIT_MILLIMETERS = 1,
};

#6

Evan,
I am just starting and need to figure out how to scale these in Meshmixer by Autodesk. It is a nice simple program to trim scanned molds, but scaling seems to be harder to figure out. I need the scan to be actual size in inches.