Severe sensor issues Structure Sensor (Mark II)


So, I have had my mkII sensor for a few days, and have had absolutely Zero luck getting even a basic scan. I have noticed a few things during the troubleshooting process, and wanted to see if I am alone in this??

  1. Battery life - I can get about 20 minutes MAX during my troubleshooting session before the sensor starts going even MORE unstable (which believe me, is a hard thing to do) and reports that it is low on power necessitating a charge. I do not know what the expected session time is for the sensors, but I have to imagine that 20 minutes or less is not it.
    1a. When charging off of any power source (I have tried high Amperage capable chargers just to see if it was hungry) the light moves to a flashing blue as expected, but very quickly, far more quickly than is possible for a full charge, the light will change to a solid blue indicating that it has completed charging. Even so, whether I believe it or not to be full (i.e., whether I let it charge all night or just the time it said) the results are the same, ~20 minutes before going out.

  2. Calibration - I think I know there are a ton of known issues here. the main one I am curious to see if others have, though, is a completely black screen in the end of the process where you would normally do the manual mapping.

  3. Scanning - Even after completing a successful calibration (though without the last manual nudge) I get stuttery (flashing on and off) and sparse hits by the sensor. I am seeing about 5 percent or less hits from the sensor. This means nothing at all is scanable whether it be a room scan or an object scan.

  4. Depth sense - Possibly the cause of the previous two items… I noticed that when I am looking at the depth data returning from the device, it appears to be only seeing the edges of objects, not the faces of them. So, for example, if looking at a tripod it will see the edges of the legs in form, but nothing else (and the edges are spotty as well, but they at least show) Almost the exact opposite of what I would expect. Taking that observation a step further, it appears that it’s not just edges, it looks like like it is behaving almost the opposite of a polarized sensor… it appears the only things that are registering any depth data are those things which are REFLECTING a lot of light (which I suppose partly makes sense since the IR needs that bounce back, but these spots are very specific)

Net result = unusable sensor, has anyone else experienced the above and found a solution?

Mark ii supported apps, full body scan not working, any help please?

Experiencing the same stuff, please post solution when you get one.


@alvaroanzoategui I have heard that issue #1 has been identified as a firmware issue such that some device are reporting back significantly lower power levels than the actual level. So, the good news is it’s not a defective battery… :slight_smile: The edge-only and sparse hits may end up being a depth sensor calibration issue but not verified. I’ll post back if a solution is found. :slight_smile:


Am seeing the battery issue for sure. Didn’t see it on previous firmware, so assume that’s fixable. Have seen some instability in the Calibration app, but have managed to calibrate by force closing app if it fails, and trying multiple times. Can’t speak for issues 3 & 4, as not seeing that here.


I am having these issues also. Are there any Structure techs on this board?


@andy.warwick I was able brute force my way through calibration as you describe as well, but did you experience the 2ndary issue of the black screen on the last manual calibration tweak step?

It is sounding more and more like the show-stopper issues are all related to the depth sensor calibration. Outside of a defective unit it’s really the most logical thing, and since I can at least see the IR firing away I’m leaning towards a configuration issue, which thankfully is also only a software update. I will report back on my saga should it lead to a resolution!


No, have not experienced the black screen on tweak step. I only saw crashes of the app until I managed to brute force the process.


Thanks, that would be consistent with the current line of thinking then. I think that last screen that displays for tweaking is mostly depth data for you to be able to adjust. If so, and if my depth sensors are calibrated for Mars it seems, it could explain the “blank” result for me.


I can’t even brute my way thru calibration. I feel like I bought a completely useless tool…


I have the same issue with you. For scanning, I can not scan anything. When I try to scan, most of the time, no bounding box appear in the screen. Even sometimes, it appears, it is not stable(flicker).
In the calibration, It can only identify the edge of the objects, it is not like the original sensor, in Mark II there is no shadow(the red part in the bounding box which should cover the objects) appears. I think there are some unknow problem besides the firmware issue. If you solve the problem, could you help me too?


I have noticed the disappearing bounding box and flickering in the Scanner app is when you use the ‘Body’ preset, under the gear icon.

Using the Default preset seems fine unless you even try selecting one of the other presets. If you do, even the Default preset starts to flicker.

Suggest you force quit the app, keep the Default preset active, and don’t change it.


In fact, I used the default mode. As it does not work. We have to pay more for buying the original sensor. Comparing the two sensor, we find that in the calibration, the Mark II can only identify the edge of the objects.


This is the result for comparing original one and the Mark II. As I really need to use 3D scanner for do my experiment. I have to pay more money to buy the original one. And by the comparing, it is easy to find that there is something wrong for Mark II even in Calibration mode. Mark II can only identify the edge, can not cover the whole object. Whether there something wrong with the app setting for Calibration, or it is the hardware problem?


I’ve always calibrated out of a 5th floor office window, slowly panning across buildings opposite, rather than something indoors. Seems to give a better result, probably due to more light. Never had much luck calibrating indoors. Just tried again, doing the office internals, and did see a black screen at the end of the process.


In fact, for comparing it, I try to test the two sensor at almost the same time, and from the results, it seems that the original one can work well, and the new Mark II works worse than the original one. Thank you for your advise, I will try it tomorrow. I hope my test and the photo will help us to find the reason for the issue.


Hello everyone,

Thank you for your patience! I’m a CX Specialist with Occipital, and we have been investigating a few different issues to figure out what exactly has been happening. We have found several common problems:

  • Calibrator crashing and users being unable to use Calibrator whatsoever

  • Users being unable to pass the “blue dots” phase in Calibrator

  • An artificially low battery life indication (I will explain this momentarily)

  • Sensors not being initialized properly

  • Sensors with poor IR Offsets (I will also explain this momentarily)

  • Scanner failing to produce high-resolution scans

The good news is, none of these issues are hardware-based. The bad news is, we don’t have an ETA just yet on when these will be resolved.

Regarding Calibrator
Our engineers are hard at work to bring a better, more stable version of Calibrator and initialize the sensor more reliably without the “disconnect, launch, reconnect” method.

Regarding Battery
We have had a few user concerns about the speed at which their battery has depleted. After doing some in-house testing, we determined that Scanner and other apps are displaying “Please charge your Structure Sensor” when the battery still held a 75% charge. This is a firmware issue, and we are hard at work figuring out how to get an updated firmware version to customers. Alternatively, we are hoping that we can deploy this update via SDK instead, which would be a much more convenient solution for everyone.

How would you know if you have the IR Offset issue? Scanner’s bounding box will not settle down, appear, your sensor will only pick up the sharp vertices of objects as opposed to the planes, or you do not have a consistent color gradient masking the bounding box as it is focused on a floor or a wall. If these sound like your symptoms, drop a line at and we can send you an app to correct this. If this already sounds familiar and I have sent you an app with no UI feedback, our engineers have cut a new version of this app that should fully fix this issue.

Regarding Scanner’s Low Resolution Scans
Scanner was developed as a developer’s “sample app”, that is, an app that exists for developers to use as a launching point for their own apps. As such, we never intended it to be extremely robust, and it has a resolution limit of 50,000 faces per scan. This means that your scans will be artificially less detailed than if you were going to use, say, itSeez3D or Skanect. Once these apps are live, these issues should disappear.


Experiencing the same issues as mentioned above. I see the reply from Occipital but wanted to chime in. I have another issue wherein, if you try calibrating with a wide vision lens and then take it out and calibrate again, its impossible to go through the process.

The batter issue and the calibrator app crashing is driving me crazy and I really hope Occipital can fix those issues soon.


How do we get the firmware updates when they are available for the Mark II?
I’m an ‘end-user’ & not a developer and it looks like I ordered the Mark II before it was ready for use…
I’m experiencing many of the issues mentioned above and I don’t have the expertise to R&D a scanner that I thought was ready for use out of the box.
And what is the “disconnect, launch, reconnect” method?
What can I do?..


From a marketing perspective it looks like they have still not fully transitioned over to the MkII, though the “new” shiny links are hard to miss. This is a big enough change in capability though that I would rather be on this platform early than on the old one now, presuming we are able to overcome these new launch glitches. Using the SDK to get the firmware updates I believe would just be one way to get it to us faster, I believe the “Structure” app is what they typically use for that kind of system update/distribution, but it’s not ready. If the SDK delivery gets it to us faster, I’m all for it. :slight_smile: Keep in mind that leveraging the SDK as a method of distribution won’t come with it the skillset requirements of being a real developer, it just means installing some “extras” in the process that you may not end up using again. :slight_smile:

The disconnect,launch, reconnect is in reponse to the sensor not always initializing properly. I have found (as have others) that if it goes unresponsive, unplugging the sensor first, then closing the app, clearing it from the active processes, launching it again, and THEN connecting the sensor often will get the app and device talking. These issues are a pain, but I believe that they boil down to two root causes, so I am hopeful that they find a way to get us the firmware in the most expedient way possible, along with an upgraded calibration app that can overcome the severe alignment issues some of us are having. If you are at least partly working, though, using the reconnect method above should help you get through a full successful standard calibration and have you happily on your way. :slight_smile:


Hi, I seem to be having the same issues that are being mentioned in this thread. Battery seems to charge quite quickly but then runs out of charge after a short while. Calibration is a bit hit and miss, it sometimes does not recognise if the sensor is connected. Finally the room scan app, I just can’t seem to get it to work at all. Any firmware update on this would be great, keen to start using this. Thanks.