Severe sensor issues Structure Sensor (Mark II)

dropping in a me too here, i realize there have been some updates to things but still having the same issues with loosing tracking, blurry scans, etc… I am so glad i did not trade in my mk1 as well, as i got this paperweight for a job as a supposed ‘upgrade’ only to be faced with all this.

Add me to the list of unfortunate purchasers of the upgrade to the Mark II from the Mark I. By comparing the scan data from the two scanners, it was easy to see a problem with the depth data in the Mark II output. I was told this is a firmware calibration problem that has a fix, but why is this still an issue. I’m not too convinced this issue will be fixed soon.

Same… Also, the third party app ItSeez3D does not recognize the calibration.

I used the app to “Optimize” the depth data ir sending on the Mark II which improved the depth data, but still left a flickering screen door effect instead of a solid color that I get with the Mark I. Scanning a somewhat difficult image with the Mark II never works and totally looses orientation corrupting the data. I’ve successfully scanned the same image with the Mark I. Still serious issues with the Mark II.

@miles Rather than explain in writing what I’m experiencing with my Sensor Mark II, I just recorded what I’m doing/experiencing and uploaded it to YouTube. Link below. What am I doing wrong? I’m using a 3rd Generation iPad Pro.

Sorry about some of the scratchy noises, the iPad’s mic is right where my left hand holds the iPad. Annoying.

Thank you in advance.

@miles Tried again today with no luck. What am I doing wrong? Here’s a link to my attempt today.

@ecajuste I know you don’t work for Occiptal, but you are very active and helpful. Can you see what I’m doing wrong?

@TheThomas what you are seeing looks identical to the problems that I had when my sensor was DEEPLY out of calibration and the normal calibrator was not sufficient. Support was able to supply me with a link to a version of the calibrator app which was able to do a more in depth calibration of just the depth sensors. Like you, I was only seeing only the corner and not planar surfaces. Once I completed this my standard calibrations came back into spec and I was able to fine tune from there. Looking at your video (the rest of it) you should be lit up quite a bit more. Keep in mind I see you did focus a lot on some shiny and/or black objects, both of those things will have poor depth at times, but I saw plenty of surfaces that should have been giving you a lot more depth feedback. It also looks like, as it was for me, most of your flat surfaces don’t show much depth data, dog hair withstanding; the black spots I would expect to not return much data, the white did, but dog hair texture was probably in your favor there, even for a sensor out of whack. I would contact support asap and hopefully they can get you a clean sweep at your sensor calibration. Supposedly they rolled the changes in the advanced calibrator that they had me use back then into the main branch, but it’s possible they kept some of the deep level functionality out of the normal version still to avoid people doing more harm than good playing with it. If it’s like what I was experiencing, then there is nowhere to go but up as far as depth sensing is concerned.

I hope that helps!

1 Like

@EventHorizon Thank you! I will reach out to support. Once I get the new calibration app, I’ll make another video and post it. I am still very excited about what this sensor can/could do and want to chronicle the journey from (almost) out of the box to working perfectly so other people can see it’s possible and how to get it working. Onward and upward.

Thank you again.

Hi @TheThomas, I would suggest exactly what was said by @EventHorizon. I had almost identical issues during early development with the Mark II and getting access to the Expert Calibrator app was able to improve my experience with the object tracking. Hopefully it will help you in the same manner. Let us know how it works out.

Hello @ecajuste and @EventHorizon. I emailed Support and @miles responded pretty quickly with essentially a cut and paste of point 5 on this FAQ article

I did the check and here’s what it’s seeing:

Oh yeah, thanks for the longer video with more subjects in view. That view is so familiar it almost made me fall back into an early-release fetal position when my sensor lay there tantalizingly cool looking, yet unusable due to… that. @Miles is the man, he’s a good guy and should be able to get you fixed up quickly, hopefully his next step is to send you the expert calibrator to give a go.

Now, speaking from my personal experience, even after I got that app, I STILL had to do the calibration over… and over… and over, until I found just the right surface and distance to bounce off of and shock my sensor back into a more normal range. The process is supposed to be easy and a one shot fix, and I hope that is your experience, but don’t give up if at first it’s not returning filled planes for you at first, or for me, it would show a filled surface during the start of the test, then blip back to nothingness before wrapping up and saying it was done. With patience and experimentation it did finally work for me though (hint - in the end I found the best success using a surface that was flat, consistent in color/texture, filled the ENTIRE frame with said color/consistency, in the green to yellow distance range, and placed on a surface that did not obfuscate the view (the edge of a table in my case). The lack of hand holding sway and general movement seemed to help out. :slight_smile:

Hope that helps, and let us know how it goes!

1 Like

Apologies for the flashbacks @EventHorizon.

I was under the impression I would have to calibrate the sensor every time I use it because using the taped on 12.9” bracket, there will be slight irregularities every time I remove and reattach the bracket, requiring a recalibration. Not the case?

The solution you recommend sounds perfect for indoor use. What about outdoor use? I have seen people use photogrammetry to create 3D scans of objects they find out and about (tree stumps, cool rocks, statues…) and assumed the Sensor could do the same. But if calibration requires a sold, flat surface, that might be very hard/impossible. Would you just walk around with a sheet of cardboard or something?

Sorry I was speaking of when doing the Expert Calibrator version of calibration. That’s a one time thing to fix your sensor doing what it’s doing. For that particular exercise you just want a clean flat surface so that it can measure edge to edge the full sensor wide (it should fill the screen with nothing showing on the edges). For normal calibration after that… no you should not need to calibrate every single time you use it, but I do calibrate if I remove it entirely and put it back on for another use. Once you are dialed in though, at least in my experience scanning without a calibration every time is fine - in fact you can only calibrate when you have an internet connection, so that rules it out if you are in the field without one. But yeah for the normal calibration, a properly tuned sensor doesn’t need much special, and should acquire a calibration worth image out of a lot of scenes, I’ve used just about everything from buildings to plant boxes. The biggest thing to remember is you ware looking for a lot of defined angles, or text even… big text works really well to fill up your lock points. :slight_smile: But again you shouldn’t have many troubles once your sensor is working as it is designed. (ehem, at least with basic calibration, but then you get to graduate on to the next tier of potential issues ;)) It’s clear that Occipital is working on a number of key updates for usability though, they just have too many P1s I think, hopefully the road will get smoother once more of those have been knocked out.

@EventHorizon @ecajuste @miles And… I’m back from a business trip. I tried out the Expert Calibrator app but I’m not sure it worked. And I very stupidly forgot to turn on the mic so this is a stone cold silent movie. I did the calibration, but there was a strange, peanut shaped black abyss in the middle of the screen, so I thought I should re-do it. I re-did it but there was a strange black fuzziness at the bottom of the screen. Should I re-re-expert calibrate?

@TheThomas Welcome home, brave man getting on a plane right now without a full body suit :wink:

So, in the first calibration, that looked perfect. The peanut as you called it, is likely the sensors own array shining back at you since it’s such a reflective smooth surface. It looks like you had a good calibration at that point. The next one, definitely not normal - it’s normal to see some edge bleed etc. but what you were seeing looks like the result of a bad calibration. You just HAD to fiddle with it didn’t you?? :wink: I hit similar funky calibration results on my path to the perfect one - I would recommend you do it again, try another surface if you have to, but you want basically what you saw the first time around. I have found that once thrown off like yours seems to be now it takes a few tries to bring it back to normalcy, but if you are persistent you should be able to wrangle it back in. :slight_smile:

@EventHorizon @miles The strangest thing about being in an airport was everybody washing their hands in the bathroom. Honestly, it was the only thing different from every other time I’ve travelled.

I redid the Expert Calibrator calibration and I think it worked.

But I have a few questions…

  1. Why wouldn’t it see that flat, white wall at first? There was actually more light in the first room than in the shower.

  2. Is the “scanning box” always so jittery? Is there a way to make it smoother or something?

  3. Is there a way to make the “scanning box” not be a cube? As in, if I want to scan something that’s shaped like a refrigerator, a cube grabs too much of the surroundings.

  4. Is there a better way to know what is or isn’t inside the “scanning box?” It seemed like I had the whole computer in there but apparently I didn’t.

1 Like

Hi Andy, Which scanning app are you using?

Unsure what you mean. I calibrated with the basic app, and the Expert Calibrator when that failed. Needed to ensure we were on the latest firmware, and for development the latest SDK. The actual app we use for scanning is our own, MZ-Bodyscan.