[SOLVED] MIxed Reality Sample - Stopped working


#1

Very odd thing. I have successfully launched the Mix Reality Sample code but today when I opened it up, I was unable to scan the environment I was in. The touch menu is simply unresponsive, tap away as much as you want. Odd.

I did a rebuild from xcode. Same problem.
Deleted app from iPhone. Rebuild.
It works! Scan the environment. Muck about a bit. Close app.
Great!
Let’s try that again.
Launch the app and load the previous scan - menu is once again unresponsive.
Try rescanning the environment - can’t menu unresponsive.

What am I missing?

(xcode: 8.3.3 (8E3004b), iPhone 6s 10.3.2, OSX 10.12.5)


#2

Hi James,

Thanks for the bug report! Are you on the latest BE Beta (5.2)?


#3

This version is 5.1 - sorry should have specified :slight_smile:


#4

Thanks James,

Can you upgrade to the latest beta and test again? 5.2 It was a maintenence release which resolved a handful of issues. If you’re still encountering the bug after upgrading then we’ll definitely dig into it.


#5

Turns out 5.2 is worse.
In 5.1 I was able to run the app as soon as I built it and sent it to my phone. Not always but I would say 80% of the time.
The other 20% would get me to the “Scan or Load” menu but it was unresponsive to my taps.

5.2 gets me to the “Scan and Load” menu and no further. I tried publishing several times but no luck.

On a side note, in 5.1 I could access the “Scan and Load” menu if I enable Stereo Scanning in settings. Haven’t tried it in 5.2 so I’ll do that now.


#6

Confirming that I can access scanning and loading if I use in headset scanning and the controller. Menus before and after work just fine. Just seems to be that initial menu that becomes unresponsive. Odd.


#7

Thanks for reporting this. We’ll dig into what could be causing the issue.


#8

Tried to reproduce this, no dice here.

Here’s my config:
Xcode: 8.3.3 (8E3004b), iPhone 6s 10.3.2 (14F89), OSX 10.12.6 (16G29)
Building with Bridge Engine Beta 5.2

Have you deleted the app and started from a clean starting state?


#9

I deleted the app from the device and did a rebuild as stated in my previous notes. However, I haven’t tried starting from scratch and will grab a fresh copy of the demo to see if the problem persists.


#10

Okay. Using a fresh copy of the demo, everything is back to working. Phew.
Thanks for the suggestion Otri. I’ll soldier on now with exploring the code again :slight_smile: