Structure Core doesn't work with USB3

Hello,
my english is very bad, sorry for this.

I work with the new Structure Core (SC) and Skanect 1.10.

My Laptop is brand new (HP Omen 15-dc1211ng, with CPU i7, GPU NVidia GTX1650). Win 10.

The problem is, that the SC is connected in USB3 port, but Win 10 tells me, that it works with USB 2 Standard. (“The device could work faster, if it is connected in USB3 port”).
Result: in Skannect, it scans only with 17fps and scan will be interrupted by evry littler faster movement.

All firmeware-Updates are done, all drivers are new, the OpenNI is installed, in PN1080.ini usbinterface=2.

What can I do, or what is the mistake?

Thanks for help in advance.

Thomm

Hello,

sorry for my english too

same for me about usb 2.0 sometimes,
with Windows 10 (v1909), Intel NUC I5, GTX 980 External.
StructureCore , Skanect 1.10

Windows 10 problem ?? i dont know.

if USB 2.0, …and if you are sure that your laptop USB port is a real 3.0 one (active in bios ok ?)
and drivers ok.

  • Try to unplug and re-plug the usb cable, and do it again if it doesn’t connect in 3.0.
    ( for me the second try is usually the good one, …coreplayground says : USB 3.0 connected)

  • If your USB cable is no well connected (ex : adapter) or not the original one,
    or if you have a cheap extension, it can be the problem too
    ( all the cables i tried did not work)

I run my Core with a “good” 3 meters 3.0 cable (not the original) and it works perfect with a solid usb3.0 in Skanect

let us know if this work for you : )

alex

Thanks for your answer,

in the meantime the issue had solved by itself.

Nevertheless, I am very disappointed with the scan result. It is hardly possible to run a scan without interruptions. Years ago we had experience with Skanect and Kinect. Since then, however, there has been no major improvement.

The promise of 60fps in the spec of structure core I can’t comprehend. We reach max 19fps.

Best regards

Thomm