StructureCoreDepthRangeMode::VeryShort doesn't work?


#1

I’ve got a brand new colour Structure Core, I’m running the latest SDK (just downloaded) on Windows and I’ve run the firmware upgrade as well.

I’ve opened the VS solution that comes with the samples and I’m running the Recorder app. It works but I want to set the depth range to be closer.

If I set the depth to “VeryShort” just by adding this one line of code, all I see is a blank screen where the depth should be - it doesn’t seem to pick up the depth at all:

cmd.captureSessionSettings.structureCore.depthRangeMode = StructureCoreDepthRangeMode::VeryShort;

I can set it to Short and other levels, but Short does not seem to pick up anything much closer than a meter, and the other settings don’t help much either.

Is there something else I need to do or set to get close in scanning (the closer the better) or is this a bug?


#2

VeryShort preset is for depth closer than a foot away from the object your are viewing. Could you put the Structure Core closer to see if it picks up some depth?


#3

Hi Anthony,

Thanks for your reply. I’ve tried lots of different depths. The most definitive test is having the scanner on my desk facing me and then putting in my hand in front of it (touching) and then moving away slowly to a distance of 2m+. At very close up I see one vertical line sometimes, but otherwise nothing, just the white screen.

I could record a video of me doing that if it helps, but let me know what would work best.

And just to confirm, I’m running the SDK code Windows tutorial exactly as it comes with just that one line of code added. The Short setting does work (seems to be around about 50cm it kicks in though) but VeryShort doesn’t.

I’m looking to scan close in so this setting is pretty vital for me. Thanks for your help!


#4

Thanks for the quick reply!

Could you take a video of your cycling through the various depth rage modes?

Can you try CorePlayGround on a Mac?