StructureUnityUBT Plugin examples not working


#1

Hello all,

I built the Unity UBT San Francisco demo on my iPhone 7 with the Structure sensor attached to the bridge HMD. The app loads on the phone correctly and I am able to look around the apartment but I’m not able to move around when I move the HMD. I can move however by tapping the screen.

I looked through the pdf but I didn’t see any troubleshooting about this. I am using different versions of programs than the recommended versions only because of the device I’m using. I’m using Unity 2017.1.0f3, Xcode 9.2, and the iphone has iOS 11.2.1

I’ve attached the log I get out of Xcode

Any ideas or things to try?

Thanks,
-Cameron


#2

Hey!

I’ve been able to recreate your issue with my iPad Air 2 running iOS 11.2.5.

I’ve been able to get the Structure Unity UBT Package to work with the San Francisco scene by disconnecting and reconnecting the sensor before launching the Application. Please make sure that you have fully closed all applications that use the Structure Sensor beforehand.

Hope this helps!


#3

Hey Anthony,

I power cycled the phone, plugged in the sensor, and started the app but no positional movement, just rotation as before. I’ve also tried unplugging the sensor while the app is running and plugging the sensor back in, starting the app with the sensor unplugged and then plugging it in, and closing all applications, unplugging the sensor, plugging in the sensor, and then starting the app. I am on iOS 11.2.1 so I can try updating to 11.2.5 if you think that would help


#4

Have you tried unplugging and replugging the Structure Sensor?

Also, the StructureUBT package is known to work with the following versions of Unity:

5.1.3f1, 5.3.2p4, 5.3.3f1, 5.3.4f1 , 2017.1.1f1, & 2017.2.0f3

Please compile the sample with one of the above versions.


#5

Yes I tried unplugging and replugging the sensor before running the application and while the application is running

Did a rebuild with Unity 2017.2.0f3 but getting the same thing


#6

I ran the package with Unity 2017.1.1f1 and was able to get it to work correctly on my iPad.

I reran the test with my iPhone 8 and was able to recreate your issue. We will have one of our developers take a look into this to find a solution.


#7

We were able to find the issue with the Unity Packages on an iPhone.

Could you please try to recalibrate your iPhone without the Wide Vision Lens attached to the Bridge Headset? Let us know if this helps!


#8

Thanks! I was running into the exact same issue and removing the wide angle lens and recalibrating worked for me.

Curious, though, why we need to do this step?