Swift - Structure framework - Do not Embed vs Embed & Sign

Hello Guys,

I’ve created a new iOS swift project and I’ve imported the Structure framework.
I’m able to build and run the app on the simulator.
However it doesn’t work on the device.

I’ve set the Structure.framework to “Embed & Sign” in General
Screenshot 2020-03-01 at 15.43.27

Is that the correct setting?
Works fine on the simulator but when I deploy to my device (iPhone SE - iOS 13.3)
I receive the following error:

dyld: Library not loaded: @rpath/Structure.framework/Structure
Referenced from: /private/var/containers/Bundle/Application/60B6B30A-2A73-45E9-BBC7-3FD1C2B77B53/SensorRecorder.app/SensorRecorder
Reason: no suitable image found. Did find:
/private/var/containers/Bundle/Application/60B6B30A-2A73-45E9-BBC7-3FD1C2B77B53/SensorRecorder.app/Frameworks/Structure.framework/Structure: code signature invalid for ‘/private/var/containers/Bundle/Application/60B6B30A-2A73-45E9-BBC7-3FD1C2B77B53/SensorRecorder.app/Frameworks/Structure.framework/Structure’

/private/var/containers/Bundle/Application/60B6B30A-2A73-45E9-BBC7-3FD1C2B77B53/SensorRecorder.app/Frameworks/Structure.framework/Structure: stat() failed with errno=25

Thanks for your help

hi,

maybe this helps you out?

Thank you Thorsten, that’s very helpful.

In the meanwhile, I’m working on the Objective-C version,
less trouble

Hi @arkader,
Did you try the solution that @thorsten.steparsch gave?
That did not work for me even though I’m using the Scanner app from samples!
Thanks

– EDIT –
Okay, so this seems to be a known issue since iOS 13.3.1: