Unity VR Crashing


#1

Hi, I’ve been trying to get the BE Unity plugin working, following the PDF instructions using the RobotRoom. I cannot successfully scan a simple, small living room without the test app crashing. After I scan the room and hit the DONE button, the two stereo displays flash the RobotRoom for a second, but then the app crashes.

The only way I can get the app to continue to the VR/positional tracking experience, to see the RobotRoom, is to only scan 1/3 of the room. I’ve tried every combination of the advice I’ve read from your forums & otherwise: scanning from the center of the room, aiming at the middle of the wall, scanning slowly, scanning up and down, starting with the ground, standing in the corner of the room, etc.

The room is approx. 10’ square, 9’ ceiling, well-lit. I’m using the iPhone 7, Unity 5.5.0f3, and downloaded the Unity plugin today (1/1/2017). I’ve tried restarting the phone and reloading the test app. The same room scans just fine (all 360 degrees) when using the Bridget app, but continues to crash when trying to view the basic RobotRoom example/test app.

What’s causing this and how can I fix it?

Thanks! It’s been an exciting start, eager to get past some initial bumps.


#2

Sorry to hear things are crashing just as you start interacting. I’ve notified some folks on our team to try to diagnose it. If anyone else has experienced a similar issue and found a workaround, let me know.


#3

Hi again. Could you try to retrieve an associated crash log from your device using Xcode? Each time a crash occurs it should generate one. Here are some instructions if you’re not familiar with getting crash logs:


#4

Thanks for the quick responses, Jeff — I may be using the Bridge for a two-week research fellowship that starts tomorrow, so I really appreciate the timely investigation.

It seems that I can’t attach the crash logs directly, so a series of them can be downloaded at the link below (each one reflects various scanning approaches, as described in my original post, not sure which would be most useful to you guys):

https://dl.dropboxusercontent.com/u/75067968/Bridge%20Crash%20Logs/RobotRoom%20Crash%20Logs_raytkho.zip


#5

Thanks for the report ZIP, we’ll be looking into this. This appears similar to a recent issue we encountered when Structure Sensor batteries died. If you’re able to scan the scene, I’m fairly sure you are not experiencing the same problem. That said, can you double check that the Structure Sensor battery is charged? You can launch the Structure app, and it will tell you the battery percentage. (Not that there should not be a crash even if the battery is dead, but it would help us isolate the problem.)


#6

Great. I don’t remember what the charge was when I tried running the RobotRoom test app — but as you said, it was scanning without any problems (i.e. worked fine with the MR demo and Bridget app, and worked with RobotRoom if I only scanned a small portion of the room). The sensor is at 100% now because I’ve been charging it.


#7

Hi, just to rule out some external factors, could you give it a try with Unity version 5.4.2f2? Also, what iOS version are you using?

Last, could you enable wireless logging by following the instructions in BridgeEngineAppController.mm:25 and give us the console output?


#8

Also, just to confirm, what bridge-engine-beta commit are you using?


#9

Hi, I’m using iOS version 10.1.1. I cloned the Bridge repository on 1/1/2017 (BE beta 3, I believe).

I’ll give it a try with the older Unity version tonight, as well as the wireless logging.


#10

Hi, I have just started having an instant crash too after scanning. I am not using unity, it is straight out xcode. It is basically the Mixed Reality demo with one minor tweak. I have over written the chair.dae with another dae.

The Bridget demo is running fine so I don’t think it is my sensor battery. I will try and get crash log.

Running the latest Bridge SDK. iOS 10.2.


#11

I am getting a crash as well when using the Unity plugin. I scanned a room and once it could not scan anymore and showed the too large message it crashed after getting into Unity. Using Unity 5.4.3 and latest (beta 3) Bridge Engine.


#12

Hi, I tried with Unity 5.4.2f2, same crashing/outcome. I wasn’t able to get the wireless logging working as you described, the instructions in there didn’t work.

Thanks again for looking into this.


#13

Hi Jeff, I wanted to check in to see if there was any progress on resolving the crashing issues that we’re having. Thanks again for being so responsive and looking into this!


#14

The latest is that one engineer here was able to reproduce crashes but only when scanning relatively large areas. Unfortunately he wasn’t set up to debug, so we need a little longer.

Meanwhile however, can you confirm that this crash occurs even if you scan a small area?


#15

Experiencing the same issues here. It does seem to be only when scanning anything but a very small scene. I’ve attached one of the crash logs.
Unity_Bridge_Crash_Log_Bowen.pdf (42.6 KB)


#16

Correct, I’m in a roughly 10x10 room with 9’ ceilings, so it’s fairly small. I can only successfully scan one wall, otherwise it crashes.


#17

It crashes on the scan for me too …


#18

If this helps…

Unity Version: 5.5.0f3
Xcode: 8.2.1
Device: iPhone 6S
Device iOS verrsion: 10.2
Latest BE SDK

Thanks.


#19

Hello all,

Thanks a lot for the crash reports, they were instrumental!

We found and fixed the problem. The latest master head should not crash in Unity anymore.

Can you guys please pull and confirm that?

Thanks much!

NT


#20

PS: Please stick to Unity 5.4, as recommended in the documentation. 5.5 has known issues we are still currently squashing.