Update to the NewSDK(0.11.1) can not compile

Hi, Dear
I have upgraded the current app, and the following problems occurred during the compilation. Is there any suggestion for solving this problem?

dyld: Library not loaded: @rpath/Structure.framework/Structure

**Referenced from: /private/var/containers/Bundle/Application/2CA32BFA-BEA3-4739-

A6BB-FDD80BA1CA01/XXXXXX**

Reason: no suitable image found. Did find:

/private/var/containers/Bundle/Application/2CA32BFA-BEA3-4739-A6BB-FDD80BA1CA01/XXXXXX/Frameworks/Structure.framework/Structure: code signature invalid for '/private/var/containers/Bundle/Application/2CA32BFA-BEA3-4739-A6BB-FDD80BA1CA01/XXXXXX/Frameworks/Structure.framework/Structure’

Message from debugger: Terminated due to signal 6

Any can help?
there are no good resolution on this.

Now it compiles and runs, but I can’t package it as an ipa file.

lipo remove struct x86_64 repair it.

Hello,

Did you find a solution to this issue?
Thanks

lipo remove struct x86_64 repair it.

it can repair。

Is that a command line you run in the terminal?
Thanks

yes.
run it on your mac.
see it or google other page
https://ss64.com/osx/lipo.html

lipo is a tools.

Thank you, I’ll try that.

I’m not sure how to make it work.
On which folder do you run the command?
do you just type on the terminal: “lipo remove struct x86_64”?
Thanks

just have a try.
it’s because the arch led to itself can’t run.