Uplink to Laptop Assistance


#1

I know this question has been asked before, the uplink option not showing up in the Structure app.

Advice on the forms isn’t helping me, perhaps due to me not understanding. I bought the Structure Sensor, and an ipad, just to use Canvas. And I also want to play with the Structure app itself to scan items. But none of this intuitive for me as I was hoping it would be. Everything I’ve found make this seem like it’s a developer toy, not a consumer product, and I’m getting frustrated. Especially since searching the forum, I’ve found nothing more recent than Jan '17 on this topic. Unless I’m looking in the wrong spot?

Yes, my devices are on the same network.

Yes, I open Skanect, and then Structure. Yes, Skanect says waiting for uplink.

Connecting Structure Sensor with Uplink to skanect This thread talked about disabling unused network interfaces, but that didn’t help either. Nor did getting rid of the firewall.

I’m running a 32 bit 1.7 Version of Skanect (1.9 wouldn’t install correctly) on a Windows laptop running Windows 7. The ipad is a 5th gen, and my Structure software is the most up-to-date.

Anyone else have any suggestions for me?


#2

We would recommend setting up an Ad Hoc connection. You can find instructions here:
http://structure.io/support/how-do-i-use-uplink-without-public-wifirouter

This will help rule out that the wifi is the issue.

Still Doesn’t Work?
If you are still having issue it may be your anti-virus or firewall that may be blocking the connection. To test this theory I would recommend disabling both to see if you are able to make a connection. If you are then I would recommend alternating them in an on/off state to figure out which one is causing the issue. Once you have pinpointed the issue you should be able to set up a rule to allow communication between the devices.

It Works!
If you are able to connect then it has something to do with the wifi router. It may also be possible that your router has 2 WiFi channels with the same name which may be causing the issue. I’d check if your router has both a 2.4 GHz and 5GHz band? If so you may want to try renaming them so you can separately identify them. ie. Wifi 2.4 GHz and Wifi 5GHz

I would also check to verify your router allows both TCP and UDP traffic on port 6666.

We also find that some networks don’t work well with the Uplink mode in Skanect, so some of our customers hook up a router for their own personal use. If you are still experiencing difficulty, you might want to choose this option. Keep in mind that the router does not need to be plugged into a modem, as Skanect does not need an actual internet connection to work.

Hope this info helps!